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M Agilent VEE %4177 ! Agilent Visual Engineering Environment
(VEE) &MUy Ress R I r RS 5388, w] ROl TF A IS T) o Ay A bRkt
2>l H Agilent VEE, FRATAER T AR RS, P4l 1 iy 2 Ml FH 44
REHT A . AFRRIE B SN BRE, 0l T anfrilak USB $: 1 5408
A AR R REAU R A FAT B s BT

Z2 4% Agilent 10 Libraries

{ENESE Agilent VEE Il B8 T Agilent IO Libraries Suite #4:. i FH i 4%
PERTLAEGE SR 1. USB.  GPIB B{ LAN 4% 13k 51088315 .

MR ZAEH Agilent VEE 5 {385, WALZTE 24 Agilent VEE X {24
Agilent 10 Libraries Suite 16.1. {Hi&, WIREAMEHES, WA LLEREA
2245 Agilent 10 Libraries Suite.

o UK SO 1] PP 22 e 0 TR AR A -

1 ¥ Agilent IO Libraries Suite CD #i \ %] CD-ROM I 5/j#5% .

2 InstallShield® Wizard $4§i5 3% 58 e 3 f o #ili Next H5ZE0ABCE,
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3 b L Agilent Connection Expert Welcome Screen % . A RS
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ne Screen 3]
View and change settings a
for the selected tem

Scan, verify and
manage instrument V0
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2 efresh s instrumest

[ chengeoreoeties
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%24 Agilent VEE Pro

1 i\ Agilent VEE installation CD, #KJ5 i Install Agilent VEE Pro 9.3.
InstallShield® Wizard ¥4 5145 5¢ i 20 Fa

Agilent VEE 9.3 Installation CD

Install Agilent VEE Pro 9.3
Install Agilent VEE Runtime 9.3
Install Microsoft .NET Framework 3.5 SP1

2 InstallShield® Wizard F £ 2% 75 L %¢%% Agilent 10 Libraries Suite 16.1.
WA ke, B HBLLLT I S

Agilent VEE Pro - InstallShield Wizard

Agilent IO Libraries Suite 16.1 or greater is not found,
! Agilent VEE requires Agilent IO Libraries Suite 16.1 or greater for communicating with instruments.
Please install Agilent IO Libraries Suite 16. 1 or greater after finishing this setup.

R, WRETE Agilent VEE S35 (E, W23 Agilent 10
Libraries Suite 16.1. Kb, %75 56 B %2 3¢ 2 )5 % 4% Agilent 10
Libraries Suite 16.1 2% 5 & A .

3 i 0K, InstallShield® Wizard K15 & /&7 2 %% Microsoft NET
Framework 3.5 SP1.

4 KGN Microsoft NET Framework 3.5 SP1, K& GRUIT
“Question” XfUFHE, T REZEZHAE. $.1f Yes 7 B %2 3% Microsoft
NET Framework 3.5 SP1. ZEM %3582 5, Agilent VEE %3245 H 5)
kg, i No 2+ ik Agilent VEE (1435,
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R 224 T Microsoft .NET Framework 3.5 SP1, InstallShield®
Wizard ¥ 5 38 AT F DL D] 1 PIEET Agilent

VEE £
Question B2

2? Microsoft .NET Framework 3.5 SP1 must be installed before instaling Agilent VEE.
L/ Do you want to install Microsoft .NET Framework 3.5 SP1 now?

5 EHBLLL FXHEHERS, #di Next.

“Agilent VEE Pro 9.3 Setup. <

‘Welcome to the InstallShield Wizard for Agilent
VEE Pro

The InstallShigld® \Wizard will install Aglent VEE Pra an
wour computer. To continue, click Mest

6 ZEHI “License Agreement” SFiEHER 52V W, #RJG ¥ Next.
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Agilent VEEP10 9.3 Setup

License Agreement o
Flease read the following license agreement carefully. o
2 \ L

The license agreements contained here are for 2 different uses of this [
product. Please review and click to accept the appropriate license -
agreement for the product you are installing, either a purchased product,

or a 30-day Evaluation usage.

Evaluation License

LEGAL NOTICE: PLEAZE READ THESE LICENSE TERMS BEFORE
INSTALLING OR OTHERWISE USING THE LICENSED MATERIALS. .
ALL USE OF THESE LICENSED MATERIALS IS SUBJECT TO THE ()

(53| accept the terms of the license agreement

() da not aceept the terms of the license agresment

< Back " Mext > ][ Cancel ]

7 AHIL “Customer Information” XJiHAER #EA L4 . AT LB FRAIFE
M, AR5l Next. 7788 5 7E Agilent VEE Pro Product Key
Certificate 17,

Agilent VEE Pro 9.3 Setup

Customer Information

Please enter vour information.

Lzer Hame:

Company Mame:

Product Eey [Enter EVAL for a 30-day evaluation inzstall):

Install thiz application for:

(%) Anyone who uses this computer [all users)

) Only for me [AGILENT TECHNOLOGIES)

[ < Back I[ Mest > ][ Cancel

8 EHBLLLFXHEHERS, #oi Next #2532 BRINBCE
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ﬂgilent VEE Pro 9.3 Setup

Choose Destination Location

Select folder where setup will install files.

Setup will install Agilent YEE Pro in the following folder.

Tainstall o this folder. click Nest. To install to a different folder. click Browse and select
another folder.

Destination Folder

C:\Pragranm FileshagintiVEE Pro 9.3 [ Biowse. |

< Back " Mext > ][ Canicel ]

9 7EHBL “Setup Type” XHEHENS, %&+% Typical Setup, #AJ5 fiidi Next 5¢

Agilent VEE Pro 9.3 Setup

Setup Type
Select the setup type to inztall

Click the tupe of setup pau prefer, then click Next.

(=) Typical Frogram will be installed with the most comman options. Recommended far
moszt Lsers

() Compact Program will be installed with minimurn required options.

O Custam ou may select the options wou want to install. Recommended for advanced
LISErs.

< Back “ Mest > ][ Cancel
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IEE— NEES &m0k ad S HEn; QN OB L B, =42 740, @B38,

BF
B

5| R 12FF (All Programs) > Agilent VEE Pro 9.3 > VEE Pro 9.3 , )%/ Agilent
VEE Pro 8¢ Agilent VEE Express.

EZi Untitled - Agilent VEE Pro HEE

- Fle Edt Vew Debug Flow Device System IO Data Disply Tools Datsbase Excel lfndow Help

Program Explorer = 2 viain e
5 Untitled

> WE

THEX

“Welcome”

BA

BHwA

mibLEn

[ seswvaia 392(q0 % uonaund & | sepeusi waunasur gy

Bropeties  onx Agi|e|-|t VEE Pro Agilent Technologies

Introduction

e '7T|p of the Day
B Appearance What's New You ean view 2 VEE Object's menu by clicking
on the upper-left hand corner afthe object or

Tite Main
5 Behavior | WebDemos |, igniclicking anywhere over the object
™ Conver Infinity t False MATLAB Examples

Example Programs

I¥ Show this screen at startup
Title
Title string of the: objzct
Erry
Ready |Exectiode; vees | proF |[Mon | wes | i |

fsul LUl Agilent VEE Pro WO & 1R U5 )i 7R i . MATLAB 7~ fIFE
BIFE . ] AR RS G % H .

Rt ] DGR SR AT IF AR RE oo 4T T FE I AE Iy, 36 %% 31 File > Open
Example ... ¥ Help > Open Example....
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U RBEEHE

EAHFEF, AT E L USB £ LR RIS, fiff %3 T Agilent IO
Libraries Suite 16.1, 2R54k4:,

AR USB X4, EH T GPIB AU I BREAE L R 8 2 e AR

1 Jfd PC ERYEE USB i HIEHZLAS . AR5, FTIFAEs . K I Found
New Hardware Wizard SHEHE. NI . Next 58 Bt 5.

2 WRWA BB Agilent VEE Pro , 830 . i T EF: LK) Instrument
Manager %41 7 -

3 B I Instrument Manager T E % 1. ™. Find Instruments %41 @
PLHE A5 11 PC &R T A 18

G LG HS & e
HID
-

I:El;l I'u'II DHD: I:'I:iHI i:l:'TI
o |Find Instruments. .

4 YR HILT Identify Instrument 3 H 36 THHE, 55T Yes. 1XHF HBLIN
Bl USB % 10 E A #s. 7Rtz rh, H H I Agilent 34410A Digit
Multimeter.

Identify Instrument
Send "*IDMN?" to newlnstrument  { @USB0:2391:1543:MY45001050:0:INSTR)'?

The response to "*IDN?" provides an
@ accurate identification of this instrurment.

Mote: Older, non 488.2 campliant instruments do not

understand this command. Ifthis command causes an
errar in the instrument, cycle the power on the

instrument to reset it.
A _MNa
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5 7F “Instrument List” & #& 1 455 ¥ newInstrument. KX)o, EFF
Create Direct 1/0 Object, LA7E T {F X H i 1% % ) newinstrument [¥]
Direct I/O X%, LA % ARV & R IE BB AR, BRI

k] newlnstrument{ag3441 Da@ISE D evig

Create Direct 10 Object

|* =22

add Instrurments ...
Configure Drivers

Load Sample

Delete Instrument Dl

§ X E.

Instrument Properties ...

6 X7 Direct I/O MR A Fi5542, LUK S 455 N2 Direct I/O X%
7 B R FT7R, 48 “I/0 Transaction” SHEHEPEEA n*IDN?" (fUFES]

) o EEENIFEIN, S RT I SCPI ay 4K . Bl fF ik £ —
A, MAREAE N A, il OK Lgkst,

*IDN? 2 1] gn B8 (SCPI) fir 2 HIbsiEm &2 —, &2 e gs b &
WHARR T 5 .

4

—|newlnstrument (ag34410a @UsbDevice2) |
= Double-Click to Add Transaction = v

/0 Transaction

| wrRITE ~| | TEXT =] [P*DN?

[ DEFAULTFORMAT | EOLONM

ok | mnop | cancel

10
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8 7Ek "IDN?" il A IE BN A 2 )5, ST B e e A B Rk
newlInstrument XJ % [ SCARE LA IR 45 . BER, JEPEZH %, LUK
STRING FORAT 3C /A& READ #|44 % x % . 765 OK I, K2 B3]
a4 iy xo

|newlnstrument (ag3d410a @UshDevice2) | F
WRITE TEXT "*IDN?" EOL

= Double-Click to Add Transaction =
/0 Transaction

| READ ~| | TEXT x| K

DEFALLT MUM CHARS

SCALAR  ~

ok | mnop | cancel

9 1L+ Display > AlphaNumeric, X5 7T Direct /O X G A i) TAEX i &
—~ AlphaNumeric %% .

Display | Tools Database E;
|[:j AlphaMumeric h

r‘\a
[== Logging Alphablurneric

Indicator »

10 ILE, &AL Direct I/O X% iEH: 3 AlphaNumeric ¥ % 4 FRAR SR L
7t Direct I/O #iith s #5510, 25 HIL—AN 5 TR bR o S 20 fHim — 4k B
2, LLEHE:F) AlphaNumeric X% R4 A b RO Lo 20 8 DL S8 452
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WRITE TEXT "*IDMN?" EOL
READ TEXT x STR

= Double-Click to Add Transaction =

11 5 TR E1 Run 426401 ﬂ BAT ISR
12 AlphaNumeric X G5 SR (T H AR R AT H, W N TR.

WRITE TEXT "*IDN?" EOL
READ TEXT x 8TR
= Double-Click to Add Transaction =

x| Agilent Technologies, 344104 My45001050,2.03-2.03-0.09-43-6

13 SR AE () VEE 186, 1%1$% File > Save As, RIStk 44 h

Tutorial 1.vee.
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FELIREAE

LELLEORE T, BOGAR 3 MR AL AN s o AN TR B AR

1 W3AE Agilent VEE Pro TAEXHIEHF FF IR, 1HIEFE File > New.
X5, 1%+ Device > Virtual Source > Function Generator, J7F T /FIX Nl
B NERBUERZEN S

2 BOAEOLT, BREUE SR A R IZBTE, R 200 Hz,

Mok 1.

Device | Systemn [0 Data Display Tools Database Excel ‘Wind
= Eormula ﬁ@&ﬁﬁ{=(ﬁ
MATLAB Script
#x Function & Object Erowser Chrl+H !
[#y UserObject
%] ThreadObject
% UserFunction
Call
Lt Import Library
sl Delete Library
Sequencer
| Virtual Source ’”i Function Generatar
Reqgression |:| Pulse Generator
E[- Counter li‘ Moise Generator

Function Generator

Function | Cosine =]
Frequency | 200

Amplitude [ 1
Deofiset | 0
Phase [Deg=][ 0
Time Span 20m
Mum Points 2565

Func |
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3 1%kFf Display > XY Trace J{K; XY Trace XJ % if(1E bR £ A iligs A7 000

Display | Tools Database E:

) Alphahumeric
[=5  Logging AlphaMumeric

Indicator 3

{w¢  mY Trace
e Strip Chart

Complex Plane

4 CHERSE R A R R XY trace I K BT CRR B B éﬁli
s i og i, S AT RS, R AR E A Lk, DA
$23) XY Trace % G5 A\ b FFIX L A2 8 DLSE i #2

= XY Trace =
1

_.| Function Generatar | - | ¥ name E:
Function Cosine x| o7
Frequency 200 08
Amplitude [ 1 o
DcOffset lf Func —81 E:
Phase [Deg =] 0 [Tzt 0.2
Time Span 20m ST
Num Points 256 o

| [

X name

5 gl T HEA: B Run 3240 ﬂ , vl LLE B XY Trace W4 F RIS
T
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6 i:¥% Display > Spectrum (Freq) > Magnitude Spectrum, %X 5 7F T/EX H6
Magnitude Spectrum X %S 7E XY Trace A& T 7 .

Device  Syskem

SRR A

I/ Data | Display | Tools

SN Alphatiumeric
Indicator

{v BY Trace

¥ strip Chart
Complex Plane

sy ®ws ¥ Plob

@ Palar Plat

Y

‘waveform {Time)

Database

==3| Logging Alphakumeric

Excel  Window  Help

s Afw EHE A HEaoa

i Trace F

| Spectrum (Fredq)

— Function Genera

L4 | L'e Magnitude Spectrum L\\S&J

Picture

Function
Freguency
Amplitude
Droffset
Fhase

Time Span

MNum Points

’m Label
[z Beep
|_1 Mote Pad

Phase Spectrum

Magnitude vs Phase {Polar)
Magnitude vs Phase (Smith)

[0 | Fune
Deg - IT
20m
256

Tracel
0z

A00m

1+
1

Hname

7 58 4 R B A [R) 0 5oy 22 BRI vk, 2kl sE A E R, LU
B oA B AR ) 4 R Magnitude Spectrum S %I4T

8 Hiifi Run 41 ﬂ s ARJE M ERIE TS H) oo (T2 200 Hz 4R
5%, SR IHRIE AT K2 5 200 Hz [ 3 H 4.
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XY Irace =

= 0.3
—| Function Generator = Y name i,
Function | Cosine =] ot
Frequency | 200 02
Amplitude | 1 0
-0.2
DcOffset lf Func —1 ve
Phase Deg =[] 0 Tracet
Time Span >0m o
Num Points 558 ,

X name

= Magnitude Spectrum =]
140
Mag 420
100
a0
60

1

Tracei *°

4 [

1} 2000 4000 60007000

Freq

9 R AU R KT st L IR T R B Ok T

Function Generator =

Function
Frequency
Amplitude
DcOffset
Phase

Func |

Time Span
Mum Points 2565
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10 iiti Run #2411 ™ |, RIS ML 5 . Agilent VEE ] k-4 52 37 Hi [ 7 I 49 BT

EZAN VAL IS

= XY Trace =
1
- 0.8
= Function Generator = | rreme
Function Square = 0.4
Freguency 200 0.2
Amplitude 1 o
-0.2
DcOffset 0 Func [i—1 o
Phase Deg =] [ © Tracel
Time Span 20m 0.8
Mum Points 2565 - p B
= 0 4m  8m  12m  16m 20m
X name
= Magnitude Spectrum =

180

Mag 180

140

120

100

a0

— 80

Tracet

| [

1} 2000 4000 60007000

Freq

1M BARAE) VEE 4GS, 15 1EF% File > Save As, SR 5l Cihan 4l

Tutorial 2.vee
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Agilent VEE 9.3 #1188 ThEE

vlools

A K vTools: H#M vTools Fil DAQ vTools. % ¥ vTools £ 5
METEX G, $RACVFRE . a4 WIERAE Dhae fIFT B Thae, v H T oot
X S5 BhE. & M vTools & SCREXT R AL, W “SR-PFIg(E” A
“Pric B ” - DAQ vTools FEHE B UF 4L A AT Agilent DAQ I & 45 B A5 45
Az B 1 3 FF S0 DAQ vTools X A H T+ Agilent U2300 1 U2500 % %1
USB R E i R4

M RBIRERF

% Agilent 33500 %41, 34411A DMM Fl DSO/MSO /i #2541t T — 46 i 1)
INBIFEST o X EE s R P4 B a8 VEE X581 Agilent (2R3 T
IR PR E . A RPN BIRET VA5 S, 1§55 VEE 9.3 750 X1

Agilent £ A28 F$214 T Agilent VEE Student #0 Agilent Education
FRA
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Agilent JE#%

".i'_-:a_ =
':El-:ﬁ
| &
E5810A LAN/GPIB 82357B USB/GPIB 10833X
W #O GPIB Ha.4%
R i
82350B PCI GPIB 82351A PCle GPIB
#EO #ENO

Agilent 34t T — RIS 5 PC ER R @ ERER @yl S/~ b . IX
fF5 LAN/GPIB M. GPIB .45 PCI GPIB. PCle GPIB #1l USB/GPIB #
M. FX Agilent HEH™ SIKTEAIAE B, 15V
www.agilent.com/find/gpib,
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Agilent 32 #5. ARFZFNE BN

20

it Agilent VEE Pro , #n]LLiJj A Agilent 2 BR%EUS, LISREFEDL. Bl
TRFERE B IR SS o B AT Agilent VEE 7= 5, S5 H AU 9 3k 195
RIHF o ANTFEARFTEN

RN Agilent $RIFHAB T HIMSS . HAT, fEdb3e. WM. ARRNENA 30
Z KN A ST R Agilent VEE fif )5 %o

1% ££ http://www.agilent.com/find/veeforum A & it Agilent VEE H T [
JU4, JFiEid Agilent VEE 3R75k A 745 L KW )

72 LA R e Agilent VEE HL 2% 2] FE (LearnVEE):
http://www.agilent.com/find/learnvee.

ARG AR BY, BT LLYT ) BL R Mk A E Agilent VEE 22 B4R R

http://www.agilent.com/find/veedemos .
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Agilent VEE Pro # BhIUAE LT AR 5 WA o B4 FH FLADAE 75 RROAS R 16

ML B S, 1

1 M www.Agilent.com/find/vee | A<k I EALEE B .

2 NI SCIERAE R Agilent VEE (228 Hsg N, %, ZHEN
C-\Program Files\Agilent\VEE Pro 9.3. i NE W 5 N 8 BENLEE B S
(e 2y /8

3 $TJF Agilent VEE.

4 #1JF “Default Preferences” (File => Default Preferences). 7t “Help”
PTG AT 75 I B SR 75
5 il “OK” XM “Default Preferences” fififlE.
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